Excel: use BUSCARV para devolver múltiples valores verticalmente

Si eres usuario de Excel, seguramente habrás utilizado alguna vez la función BUSCARV para buscar y devolver un valor específico en una tabla. Pero, ¿sabías que esta poderosa función también puede devolver múltiples valores de forma vertical? En este artículo, te enseñaremos cómo utilizar la función BUSCARV para ampliar tus habilidades en Excel y hacer más eficientes tus tareas diarias de manejo de datos. ¡Sigue leyendo para descubrir cómo aprovechar al máximo esta función!


A menudo es posible que desee utilizar el BUSCARV función en Excel para devolver múltiples valores verticalmente.

Desafortunadamente, el BUSCARV La función solo puede buscar algún valor en un rango y devolver el valor correspondiente. solo para el primer partido.

Sin embargo, puede utilizar la siguiente sintaxis para buscar algún valor en un rango y devolver múltiples valores verticalmente:

=FILTER(B2:B12, D2=A2:A12)

Esta fórmula particular devuelve todos los valores del rango B2:B12 donde el valor correspondiente en el rango A2:A12 es igual al valor en la celda D2.

El siguiente ejemplo muestra cómo utilizar esta fórmula en la práctica.

Ejemplo: utilice BUSCARV para devolver varios valores verticalmente

Supongamos que tenemos el siguiente conjunto de datos en Excel que contiene información sobre los puntos anotados por jugadores de baloncesto en varios equipos:

Excel: use BUSCARV para devolver múltiples valores verticalmente

Supongamos que queremos buscar “Mavs” en la columna del equipo y devolver el valor de cada punto verticalmente.

Podemos escribir la siguiente fórmula en la celda E2 para hacerlo:

=FILTER(B2:B12, D2=A2:A12)

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Excel: use BUSCARV para devolver múltiples valores verticalmente

La fórmula devuelve correctamente los valores. 22, 15y 30.

Observe que cada uno de estos valores representa un valor en la columna de puntos que corresponde a los “Mavs” en la columna del equipo:

Excel: use BUSCARV para devolver múltiples valores verticalmente

Nota: Puede encontrar la documentación completa del FILTRAR función en excel aquí.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras operaciones comunes en Excel:

Excel: cómo utilizar BUSCARV para devolver todas las coincidencias
Excel: utilice BUSCARV para devolver un espacio en blanco en lugar de cero
Excel: Cómo usar VERDADERO o FALSO en BUSCARV

Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded

Excel: cómo utilizar la función BUSCARV para devolver múltiples valores verticalmente

La función BUSCARV de Excel es una herramienta poderosa que nos permite buscar un valor específico en una columna de datos y devolver un valor relacionado de una columna adyacente. Sin embargo, ¿qué sucede si necesitas buscar y obtener múltiples valores que coincidan con el criterio establecido?

En esta guía te mostraremos cómo utilizar la función BUSCARV de Excel para devolver múltiples valores verticalmente en solo unos simples pasos.

Paso 1: Organiza tus datos

Antes de comenzar, asegúrate de organizar tus datos en una tabla de dos columnas. En la primera columna, tendrás tus valores de búsqueda y en la segunda columna, los valores correspondientes que deseas retornar. Asegúrate de que no haya filas o columnas vacías dentro de tu rango de datos.

Paso 2: Seleccionar una celda para el resultado

Selecciona una celda en la que deseas mostrar los resultados obtenidos utilizando la función BUSCARV. Puedes elegir una celda en cualquier lugar de tu hoja de cálculo.

Paso 3: Utilizar la función BUSCARV

Ahora viene el momento clave: escribir la función BUSCARV. La sintaxis general para la función BUSCARV es la siguiente:

=BUSCARV(Valor_buscado, Rango_de_búsqueda, Número_columna, Ordenado)

  • Valor_buscado: el valor que deseas buscar en la primera columna de tu rango de datos.
  • Rango_de_búsqueda: el rango de dos columnas que contiene tus datos de búsqueda y retorno.
  • Número_columna: el número de columna en el rango de búsqueda que contiene los valores que deseas devolver.
  • Ordenado: un valor booleano que especifica si el rango de búsqueda está ordenado o no. Utiliza “VERDADERO” si está ordenado, o “FALSO” si no lo está.

Mientras que la función BUSCARV generalmente devuelve un solo valor que satisface la condición de búsqueda, podemos modificar la función para que también obtenga múltiples valores. Para hacerlo, utilizaremos la función ÍNDICE y la función COINCIDIR.

A continuación, se muestra un ejemplo de cómo modificar la función BUSCARV para devolver múltiples valores:

=ÍNDICE(Rango_valor_retorno, COINCIDIR(Valor_buscado, Rango_de_búsqueda, 0))

En este caso, el argumento Rango_valor_retorno se refiere al rango de celdas que contiene los valores que deseas devolver. El argumento COINCIDIR buscará coincidencias entre el valor buscado y el rango de búsqueda.

Recuerda que, para obtener múltiples valores, deberás arrastrar la fórmula hacia abajo para cubrir todas las celdas necesarias.

Con estos pasos, podrás utilizar la función BUSCARV de Excel para buscar y obtener múltiples valores verticalmente. Recuerda que esta es solo una de las muchas funciones útiles que Excel ofrece para facilitar tus tareas diarias.

¡Para obtener más información sobre la función BUSCARV y otras funciones de Excel, te recomendamos consultar la documentación oficial de Microsoft Office!

Deja un comentario