Excel: BUSCARV si la celda contiene palabra dentro del texto

¿Alguna vez has querido encontrar rápidamente una palabra dentro de una gran hoja de cálculo de Excel? Si es así, entonces estás en el lugar correcto. En este artículo, te mostraremos cómo utilizar la función BUSCARV en Excel para buscar una palabra específica dentro del texto de una celda. Con esta función, podrás ahorrar tiempo y esfuerzo al encontrar la información que necesitas en tus hojas de cálculo. ¡Sigue leyendo para descubrir cómo hacerlo!


Puede utilizar la siguiente fórmula BUSCARV para buscar celdas que contengan una palabra específica dentro de una cadena de texto:

=VLOOKUP("*"&A11&"*",A2:B8,2,FALSE)

Esta fórmula particular buscará la celda en el rango A2:B8 que contiene la palabra en la celda A11 y devolver el valor correspondiente en la segunda columna.

El siguiente ejemplo muestra cómo utilizar esta fórmula en la práctica.

Ejemplo: BUSCARV si la celda contiene una palabra dentro del texto

Supongamos que tenemos el siguiente conjunto de datos que muestra las ventas totales realizadas en varias tiendas:

Excel: BUSCARV si la celda contiene palabra dentro del texto

Ahora supongamos que queremos buscar la tienda que contiene la palabra «Axel» y devolver el valor de venta correspondiente.

Podemos utilizar la siguiente fórmula para hacerlo:

=VLOOKUP("*"&A11&"*",A2:B8,2,FALSE)

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Excel: BUSCARV si la celda contiene palabra dentro del texto

Esta fórmula BUSCARV puede buscar «Axel» en la lista de nombres de tiendas y devolver el valor de ventas correcto de 30.

Tenga en cuenta que esta fórmula tampoco distingue entre mayúsculas y minúsculas.

Esto significa que si usamos «axel», la fórmula aún podrá encontrar este texto en la lista de nombres de tiendas:

Excel: BUSCARV si la celda contiene palabra dentro del texto

La fórmula aún devuelve el valor de ventas correcto de 30.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras operaciones comunes en Excel:

Excel: Cómo encontrar duplicados usando BUSCARV
Excel: cómo utilizar BUSCARV para devolver todas las coincidencias
Excel: cómo utilizar BUSCARV para devolver varias columnas

Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded




Excel: BUSCARV si la celda contiene palabra dentro del texto

Frequently Asked Questions: Excel BUSCARV con celdas que contienen palabras dentro del texto

La función BUSCARV es una de las herramientas más utilizadas en Excel para buscar un valor específico en una columna y obtener el contenido de la celda correspondiente en otra columna de la misma fila. Sin embargo, a menudo surge la duda sobre cómo utilizar BUSCARV cuando la celda contiene una palabra específica dentro del texto. Aquí te presentamos respuestas a las preguntas más frecuentes relacionadas con esta función.

¿Cómo puedo utilizar BUSCARV si la celda contiene una palabra específica?

Para utilizar BUSCARV en este caso, necesitarás combinarla con otras funciones de Excel, como ESNUMERO, IZQUIERDA y DERECHA. A continuación se muestra un ejemplo de cómo puedes hacerlo:

  1. En la celda donde deseas obtener el valor buscado, utiliza la siguiente fórmula: =SI(ESNUMERO(ENCONTRAR(«palabra», A2)), BUSCARV(«palabra», A2:B6, 2, FALSO), «»)
  2. Reemplaza «palabra» con la palabra específica que deseas buscar.
  3. A2 representa la celda en la cual deseas buscar la palabra. B6 es el rango de búsqueda que contiene la palabra y el valor correspondiente que deseas obtener. Asegúrate de ajustar estos rangos según tus necesidades.
  4. La función BUSCARV buscará la palabra en el rango especificado y devolverá el valor correspondiente si la encuentra. En caso contrario, devolverá una cadena vacía.

¿Qué sucede si la palabra que quiero buscar no está exactamente en la celda?

Si la palabra que deseas buscar no está exactamente en la celda, puedes utilizar las funciones IZQUIERDA y DERECHA para extraer una parte del texto que coincida con la palabra que buscas. Aquí tienes un ejemplo:

  1. En la celda donde deseas obtener el valor buscado, utiliza la siguiente fórmula: =SI(ESNUMERO(ENCONTRAR(«palabra», IZQUIERDA(A2, LARGO(A2)-4))), BUSCARV(«palabra», A2:B6, 2, FALSO), «»)
  2. Reemplaza «palabra» con la palabra específica que deseas buscar.
  3. A2 representa la celda en la cual deseas buscar la palabra. B6 es el rango de búsqueda que contiene la palabra y el valor correspondiente que deseas obtener. Ajusta estos rangos según tus necesidades.
  4. La función IZQUIERDA extraerá una parte del texto en la celda, excluyendo los últimos 4 caracteres (ajusta este número según sea necesario).
  5. La función BUSCARV buscará la palabra en el rango especificado y devolverá el valor correspondiente si la encuentra. En caso contrario, devolverá una cadena vacía.

Asegúrate de ajustar los rangos y los detalles de la fórmula según tus necesidades y la estructura de tus datos en Excel.

Para obtener más información sobre cómo utilizar BUSCARV y otras funciones de Excel, puedes consultar los siguientes recursos:

Esperamos que estas respuestas a las preguntas frecuentes te ayuden a utilizar BUSCARV cuando las celdas contienen palabras dentro del texto. Recuerda que la práctica y la experiencia te harán mejorar en el uso de esta función y otras herramientas de Excel.


Deja un comentario