Excel: cuente el número de valores “Sí” y “No” en el rango

Contar los valores “Sí” y “No” en una hoja de cálculo puede ser una tarea tediosa, especialmente si tienes una gran cantidad de datos. Pero no te preocupes, con Excel puedes simplificar este proceso y obtener los resultados que necesitas en cuestión de segundos. En este artículo, te mostraremos cómo contar el número de valores “Sí” y “No” en un rango particular utilizando una fórmula sencilla pero efectiva. ¡Así que prepárate para aprender algunos trucos útiles y agilizar tu trabajo con Excel!


Puede utilizar las siguientes fórmulas para contar el número de valores “Sí” y “No” en un rango particular en Excel:

Fórmula 1: contar el número de valores “Sí”

=COUNTIF(B2:B21, "Yes")

Fórmula 2: contar el número de valores “No”

=COUNTIF(B2:B21, "No")

Método 3: contar el porcentaje de valores “Sí”

=COUNTIF(B2:B21, "Yes")/COUNTA(B2:B21)

Método 4: contar el porcentaje de valores “no”

=COUNTIF(B2:B21, "No")/COUNTA(B2:B21)

El siguiente ejemplo muestra cómo utilizar cada fórmula en la práctica con el siguiente conjunto de datos en Excel que muestra si varios estudiantes aprobaron o no un curso en particular:

Excel: cuente el número de valores "Sí" y "No" en el rango

Ejemplo: cómo contar los valores “Sí” y “No” en Excel

Podemos escribir las siguientes fórmulas en las siguientes celdas para contar el número de valores “Sí” y “No” en el rango. B2:B21:

  • E1: =CONTAR.SI(B2:B21, “Sí”)
  • E2: =CONTAR.SI(B2:B21, “No”)
  • E3: =CONTAR.SI(B2:B21, “Sí”)/CONTARA(B2:B21)
  • E4: =CONTAR.SI(B2:B21, “No”)/CONTARA(B2:B21)

La siguiente captura de pantalla muestra cómo utilizar estas fórmulas en la práctica:

Excel: cuente el número de valores "Sí" y "No" en el rango

De la salida podemos ver:

  • Había 9 valores totales “Sí” en la columna B.
  • Había 11 total de valores “No” en la columna B.
  • Un total de 45% de celdas fueron iguales a “Sí” en la columna B.
  • Un total de 55% de celdas eran iguales a “No” en la columna B.

Tenga en cuenta que el CONTA La función cuenta el número de celdas en un rango que no están vacías.

Al dividir el resultado de la CONTAR.SI función por el CONTA función, podemos calcular el porcentaje de los valores totales que son iguales a “Sí” o “No” en la columna B.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras operaciones comunes en Excel:

Cómo contar palabras específicas en Excel
Cómo contar valores únicos por grupo en Excel
Cómo usar CONTAR.SI con múltiples rangos en Excel

Cannot search an empty string. A search keyword is required.




Excel: cuente el número de valores “Sí” y “No” en el rango – Preguntas frecuentes




Excel: cuente el número de valores “Sí” y “No” en el rango – Preguntas frecuentes

Excel es una herramienta poderosa para realizar cálculos y análisis de datos. Una pregunta común que surge al usar Excel es cómo contar el número de valores “Sí” y “No” en un rango específico. En este artículo, resolveremos esta pregunta frecuente y proporcionaremos una guía paso a paso para realizar esta tarea.

¿Cómo contar el número de valores “Sí” y “No” en un rango de Excel?

Para contar el número de valores “Sí” y “No” en un rango de Excel, podemos usar la función CONTAR.SI. A continuación, encontrarás los pasos para hacerlo:

  1. Selecciona la celda donde deseas mostrar el resultado del conteo.
  2. Escribe la siguiente fórmula en la celda: =CONTAR.SI(rango, “Sí”)
  3. Presiona Enter para obtener el resultado.
  4. Repite los pasos anteriores para contar el número de valores “No” en el mismo rango cambiando la fórmula a: =CONTAR.SI(rango, “No”)

¡Y eso es todo! Ahora tendrás el número de valores “Sí” y “No” en el rango seleccionado de Excel. Recuerda asegurarte de reemplazar “rango” con la referencia adecuada al rango que quieres contar.

Si necesitas más información sobre la función CONTAR.SI o sobre otras funciones de Excel, puedes consultar la documentación oficial de Microsoft.

Conclusión

Contar el número de valores “Sí” y “No” en un rango de Excel es una tarea sencilla utilizando la función CONTAR.SI. Esperamos que esta guía haya sido útil para ti y hayas encontrado las respuestas a tus preguntas frecuentes sobre este tema.

Si tienes más preguntas o necesitas ayuda adicional, no dudes en consultar otros recursos en línea o la comunidad de usuarios de Excel. ¡Explora todas las posibilidades de Excel y aprovecha al máximo esta herramienta versátil!


Deja un comentario