Excel: cómo sumar celdas con texto y números

¿Sabías que Excel no solo te permite realizar cálculos matemáticos, sino también sumar celdas con texto y números? Si eres usuario de Excel y quieres aprender cómo realizar esta interesante y útil función, estás en el lugar correcto. En este artículo, te enseñaremos paso a paso cómo sumar celdas que contengan tanto texto como números en Excel. No te pierdas esta oportunidad de ampliar tus conocimientos y aprovechar al máximo esta poderosa herramienta de hojas de cálculo. ¡Comencemos!


Puede utilizar la siguiente fórmula básica para sumar celdas en Excel que contienen números y texto:

=SUM(SUBSTITUTE(B2:B8, "some_text", "")+0)

Esta fórmula particular elimina la cadena de texto “algún_texto” de cada celda del rango B2:B8 y luego calcula la suma de los valores en el rango B2:B8.

Los siguientes ejemplos muestran cómo utilizar esta fórmula en la práctica.

Ejemplo 1: calcular la suma de celdas con texto y números

Supongamos que tenemos el siguiente conjunto de datos que muestra el número total de ventas en siete tiendas diferentes:

Excel: cómo sumar celdas con texto y números

Para calcular la suma de las ventas, podemos escribir la siguiente fórmula en la celda B10:

=SUM(SUBSTITUTE(B2:B8, " items", "")+0)

Una vez que presionamos Ingresarse mostrará la suma de los ítems:

Excel: cómo sumar celdas con texto y números

La suma de los artículos vendidos es 97.

Esta fórmula simplemente sustituyó un espacio en blanco donde solían estar los “elementos” en cada celda y luego calculó la suma de los valores restantes en las celdas.

Ejemplo 2: calcular la suma de celdas con texto y números diferentes

Supongamos que tenemos el siguiente conjunto de datos que muestra el número total de ventas en siete tiendas diferentes:

Excel: cómo sumar celdas con texto y números

Para calcular la suma de las ventas, podemos escribir la siguiente fórmula en la celda B10:

=SUM(SUBSTITUTE(SUBSTITUTE(B2:B8, " items", ""), "things", "")+0)

Una vez que presionamos Ingresarse mostrará la suma de los valores de la columna B:

Excel: cómo sumar celdas con texto y números

La suma de los artículos vendidos es 97.

Esta fórmula simplemente sustituyó un espacio en blanco donde solían estar “elementos” y “cosas” en cada celda y luego calculó la suma de los valores restantes en las celdas.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras tareas comunes en Excel:

Cómo reemplazar celdas en blanco con cero en Excel
Cómo reemplazar valores #N/A en Excel
Cómo sumar si las celdas contienen texto en Excel

Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded




Excel: cómo sumar celdas con texto y números

Excel: cómo sumar celdas con texto y números

¿Te enfrentas al desafío de sumar celdas en Excel que contienen tanto texto como números? No te preocupes, en este artículo te mostraremos cómo realizar esta tarea de manera eficiente y sencilla.

Paso 1: Seleccione las celdas a sumar

En primer lugar, debemos seleccionar las celdas que deseamos sumar. Excel nos permite seleccionar múltiples celdas manteniendo presionada la tecla Shift o Ctrl mientras hacemos clic en ellas. Asegúrate de incluir todas las celdas relevantes en tu selección.

Paso 2: Utilice la función SUMA

Una vez que hayas seleccionado las celdas, podemos utilizar la función SUMA para realizar el cálculo. Para hacer esto, puedes escribir “=SUMA(” seguido de la referencia a las celdas seleccionadas, separadas por comas. Por ejemplo, si tus celdas se encuentran en la columna A, puedes escribir “=SUMA(A1,A2,A3)”.

Excel ignorará automáticamente el texto en las celdas seleccionadas y solo sumará los valores numéricos. Sin embargo, es posible que obtengas un mensaje de error si alguna de las celdas no contiene un valor numérico.

Paso 3: Utilizar la función SUMAR.SI o SUMAR.SI.CONJUNTO

Si deseas sumar solo las celdas que contienen un texto o número específico, puedes utilizar las funciones SUMAR.SI o SUMAR.SI.CONJUNTO. Estas funciones te permiten especificar un criterio de búsqueda y sumar solo las celdas que cumplen con ese criterio.

Para utilizar la función SUMAR.SI, debes proporcionar un rango de celdas a evaluar, el criterio de búsqueda y el rango de celdas a sumar si se cumple el criterio. Por ejemplo, puedes escribir “=SUMAR.SI(A1:A10, “texto”, B1:B10)” para sumar las celdas en el rango B1:B10 si contienen el texto “texto”.

Si deseas utilizar múltiples criterios, puedes utilizar la función SUMAR.SI.CONJUNTO. Esta función te permite especificar múltiples rangos de celdas a evaluar y sus respectivos criterios de búsqueda. Por ejemplo, puedes escribir “=SUMAR.SI.CONJUNTO(A1:A10, “texto”, B1:B10, “>10″)” para sumar las celdas en el rango B1:B10 si contienen el texto “texto” y tienen un valor mayor que 10.

Recuerda reemplazar “texto” con el criterio que estás buscando y ajustar los rangos de celdas según tus necesidades.

Con estos pasos sencillos, podrás sumar celdas que contengan tanto texto como números en Excel. ¡Explora las funciones mencionadas y aprovecha al máximo tus datos!

Para obtener más información sobre las funciones de Excel mencionadas, consulta los siguientes recursos:

  1. Función SUMA de Excel – Microsoft Support
  2. Función SUMAR.SI de Excel – Microsoft Support
  3. Función SUMAR.SI.CONJUNTO de Excel – Microsoft Support


Deja un comentario