Cómo realizar una BUSCARV con dos valores de búsqueda

¿Quieres aprender a realizar una BUSCARV con dos valores de búsqueda en Excel? ¡Has llegado al lugar correcto! En este artículo te mostraremos paso a paso cómo realizar esta función tan útil y poderosa. Aprenderás cómo combinar dos criterios de búsqueda para obtener la información precisa que necesitas en tus hojas de cálculo. Ya no tendrás que limitarte a una única búsqueda, sino que podrás realizar búsquedas más específicas y obtener resultados más acertados. Sigue leyendo para descubrir todos los detalles y sorprende a todos con tus habilidades en Excel. ¡Empecemos!


Puede utilizar la siguiente fórmula básica para realizar una BUSCARV con dos valores de búsqueda en Excel:

=VLOOKUP(F1&F2,CHOOSE({1,2},A2:A10&B2:B10,C2:C10),2,FALSE)

Esta fórmula particular busca los valores en F1 y F2 en los rangos A2:A10 y B2:B10respectivamente, y devuelve el valor correspondiente en el rango C2:C10.

El siguiente ejemplo muestra cómo utilizar esta fórmula en la práctica.

Ejemplo: realizar BUSCARV con dos valores de búsqueda

Supongamos que tenemos el siguiente conjunto de datos en Excel que muestra los puntos anotados por varios jugadores de baloncesto:

Cómo realizar una BUSCARV con dos valores de búsqueda

Ahora supongamos que nos gustaría utilizar un BUSCARV función para encontrar el valor de puntos que corresponde a un valor de equipo de mavs y un valor de posición de Centro.

Para hacerlo, podemos escribir la siguiente fórmula en la celda F3:

=VLOOKUP(F1&F2,CHOOSE({1,2},A2:A10&B2:B10,C2:C10),2,FALSE)

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Cómo realizar una BUSCARV con dos valores de búsqueda

La fórmula devuelve un valor de 31.

Este es el valor de puntos correcto que corresponde al jugador en la mavs equipo que tiene una posición de Centro.

Tenga en cuenta que podemos cambiar los valores en la columna F para encontrar el valor de los puntos para un jugador diferente.

Por ejemplo, si cambiamos el Equipo a Espuelas y la Posición para Guardiael BUSCARV La función se actualizará automáticamente para encontrar el valor de puntos para este jugador:

Cómo realizar una BUSCARV con dos valores de búsqueda

La fórmula devuelve el valor de puntos correcto de 40.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras tareas comunes en Excel:

Cómo calcular un porcentaje ponderado en Excel
Cómo multiplicar una columna por un porcentaje en Excel
Cómo calcular el rango percentil en Excel

Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded

Cómo realizar una BUSCARV con dos valores de búsqueda

La función BUSCARV es una de las más utilizadas en Microsoft Excel, ya que permite buscar un valor específico en una columna y retornar el valor correspondiente de otra columna en la misma fila. No obstante, en ciertas ocasiones, necesitamos realizar una búsqueda con dos valores en lugar de uno solo. En este artículo, aprenderemos cómo realizar una BUSCARV con dos valores de búsqueda.

Paso 1: Preparar los datos

Antes de comenzar con la función BUSCARV, es importante asegurarse de que los datos estén correctamente organizados. Asegúrese de que los dos valores de búsqueda estén en diferentes columnas y sean fácilmente identificables. Además, asegúrese de que las columnas de búsqueda contengan valores únicos, de lo contrario, la función BUSCARV no funcionará correctamente.

Paso 2: Crear una columna auxiliar

Para realizar una BUSCARV con dos valores de búsqueda, necesitaremos crear una columna auxiliar que combine los dos valores. Por ejemplo, si los valores de búsqueda se encuentran en las columnas A y B, podemos utilizar la siguiente fórmula en la columna C: =A1&”-“&B1. Esta fórmula une los valores de las celdas A1 y B1 con un guion en medio.

Paso 3: Utilizar la función BUSCARV

Una vez que tenemos nuestra columna auxiliar lista, podemos utilizar la función BUSCARV para buscar los dos valores a la vez. La sintaxis de la función BUSCARV es la siguiente:

=BUSCARV(valor_buscado, rango_busqueda, número_columna, [aproximado])

Para utilizarla con dos valores de búsqueda, debemos asegurarnos de que el argumento valor_buscado se refiera a la columna auxiliar. Además, el argumento rango_busqueda debe incluir tanto la columna auxiliar como la columna en la que deseamos encontrar el valor correspondiente. Por último, el argumento número_columna debe indicar la columna en la que se encuentra el valor que deseamos retornar.

Ejemplo práctico

Imaginemos que tenemos una hoja de cálculo en la que deseamos buscar el precio de un producto específico en base a su nombre y categoría. La columna A contiene los nombres de los productos, la columna B contiene las categorías y la columna C contiene los precios. Utilicemos la función BUSCARV para obtener el precio de un producto con nombre “Camisa” y categoría “Ropa”.

  1. Creamos una columna auxiliar en la columna D utilizando la fórmula =A1&”-“&B1.
  2. En la celda E1, utilizamos la función BUSCARV de la siguiente manera: =BUSCARV(“Camisa-Ropa”, D1:C, 2, FALSO). Esto buscará el valor “Camisa-Ropa” en la columna D y retornará el valor de la columna C correspondiente.

Recuerde que puede modificar los valores de búsqueda en la fórmula según sus necesidades. Además, asegúrese de ajustar los rangos de búsqueda y los números de columna de acuerdo con la estructura de su hoja de cálculo.

Con estos simples pasos, ahora puede realizar una BUSCARV con dos valores de búsqueda en Excel. Recuerde practicar y experimentar con diferentes configuraciones para obtener los resultados deseados.

Fuentes externas útiles:

  1. Documentación de Microsoft Excel sobre la función BUSCARV
  2. Artículo sobre la función BUSCARV con dos valores de búsqueda

Deja un comentario