Excel: utilice CONTAR.SI para contar en varias columnas

Ya sea que estés trabajando en un proyecto escolar o en un informe laboral, la utilidad de Excel para organizar y analizar datos es innegable. Si alguna vez te has preguntado cómo contar valores en varias columnas de forma rápida y eficiente, entonces estás en el lugar correcto. En este artículo, te mostraremos cómo utilizar la función CONTAR.SI en Excel para contar en múltiples columnas, ahorrándote tiempo y esfuerzo en el proceso. ¡Sigue leyendo para descubrir cómo hacerlo!


Puedes usar el CONTAR.SI función en Excel para contar el número de filas que cumplen con los criterios en varias columnas.

Aquí hay tres formas comunes de usar el CONTAR.SI funcionar en varias columnas:

Método 1: utilizar CONTAR.SI en varias columnas con lógica AND

=COUNTIFS(A2:A11, "Mavs", B2:B11, "Guard", C2:C11, ">15")

Esta fórmula particular cuenta el número de filas donde el valor en A2:A11 es igual a “Mavs” y el valor en B2:B11 es igual a “Guardia” y el valor en C2:C11 es mayor que 15.

Método 2: utilizar CONTAR.SI en varias columnas con lógica OR

=COUNTIFS(A2:A11, "Mavs")+COUNTIFS(A2:A11, "<>Mavs", B2:B11, "Guard")

Esta fórmula particular cuenta el número de filas donde el valor en A2:A11 es igual a “Mavs” o el valor en B2:B11 es igual a “Guardia”.

Método 3: Utilice CONTAR.SI en varias columnas con lógica Y/O

=COUNTIFS(A2:A11, "Mavs", B2:B11, "Guard") + COUNTIFS(A2:A11, "Spurs", B2:B11, "Center")

Esta fórmula particular cuenta el número de filas donde el valor en A2:A11 es “Mavs” y el valor en B2:B11 es “guardia” o donde el valor en A2:A11 es “Spurs” y el valor en B2:B11 es “Centro”.

Los siguientes ejemplos muestran cómo utilizar cada método en la práctica con el siguiente conjunto de datos en Excel que contiene información sobre varios jugadores de baloncesto:

Excel: utilice CONTAR.SI para contar en varias columnas

Ejemplo 1: Utilice CONTAR.SI en varias columnas con lógica AND

Podemos escribir la siguiente fórmula en la celda D2 para contar el número de filas donde está el equipo “Mavs” y el puesto es “Guardia” y el valor de los puntos es mayor que 15:

=COUNTIFS(A2:A11, "Mavs", B2:B11, "Guard", C2:C11, ">15")

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Excel: utilice CONTAR.SI para contar en varias columnas

El número total de jugadores que cumplen estos tres criterios es 1.

Específicamente, podemos ver que el jugador de la fila número 3 es el único que cumple estos tres criterios.

Ejemplo 2: Utilice CONTAR.SI en varias columnas con lógica OR

Podemos escribir la siguiente fórmula en la celda D2 para contar el número de filas donde está el equipo “Mavs” o el puesto es “Guardia:

=COUNTIFS(A2:A11, "Mavs")+COUNTIFS(A2:A11, "<>Mavs", B2:B11, "Guard")

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Excel: utilice CONTAR.SI para contar en varias columnas

El número total de jugadores que cumplen estos tres criterios es 7.

Nota: En el segundo CONTAR.SI En esta función teníamos que especificar que el equipo no debía ser igual a los “Mavs” para no contar dos veces a los guardias del equipo de los Mavs.

Ejemplo 3: Utilice CONTAR.SI en varias columnas con lógica Y/O

Podemos escribir la siguiente fórmula en la celda D2 para contar el número de filas donde el jugador es un Mavs Guard o un Spurs Center:

=COUNTIFS(A2:A11, "Mavs", B2:B11, "Guard") + COUNTIFS(A2:A11, "Spurs", B2:B11, "Center")

La siguiente captura de pantalla muestra cómo utilizar esta fórmula en la práctica:

Excel: utilice CONTAR.SI para contar en varias columnas

El número total de jugadores que cumplen estos tres criterios es 3.

Recursos adicionales

Los siguientes tutoriales explican cómo realizar otras tareas comunes en Excel:

Cómo usar CONTAR.SI con un rango de fechas en Excel
Cómo usar CONTAR.SI con O en Excel
Cómo CONTAR SI mayor pero menor que algún número en Excel

Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded

Excel: Utilice CONTAR.SI para contar en varias columnas

En Excel, a menudo necesitamos realizar distintas operaciones de conteo en nuestras hojas de cálculo. Una de las funciones más útiles para contar datos en varias columnas es la función CONTAR.SI. En este artículo, exploraremos cómo utilizar CONTAR.SI para contar en varias columnas y resolveremos algunas preguntas frecuentes relacionadas con esta función.

¿Qué es la función CONTAR.SI de Excel?

CONTAR.SI es una función de Excel que nos ayuda a contar la cantidad de celdas que cumplen con un criterio específico en un rango determinado. Su sintaxis básica es:

=CONTAR.SI(rango, criterio)

Donde rango es el rango de celdas en el cual deseamos buscar, y criterio es el criterio que deben cumplir las celdas para ser contadas. Por ejemplo, si queremos contar cuántas celdas en un rango son mayores que 10, usaríamos la fórmula:

=CONTAR.SI(rango, «>10»)

¿Cómo utilizar CONTAR.SI en varias columnas?

En ocasiones, necesitamos contar la cantidad de celdas que cumplen un criterio en varias columnas. Para ello, podemos utilizar la función CONTAR.SI con rangos que abarquen todas las columnas en las que queremos contar.

Por ejemplo, supongamos que tenemos una hoja de cálculo con información sobre ventas mensuales de distintos productos en tres regiones diferentes. Queremos contar la cantidad de ventas para un producto específico en todas las regiones. Podemos utilizar la siguiente fórmula:

=CONTAR.SI(rango_1, criterio) + CONTAR.SI(rango_2, criterio) + CONTAR.SI(rango_3, criterio)

Donde rango_1, rango_2 y rango_3 son los rangos correspondientes a cada región, y criterio es el criterio de búsqueda. La función CONTAR.SI se aplicará individualmente a cada rango y luego sumará los resultados.

Preguntas frecuentes sobre CONTAR.SI en Excel

  1. ¿Puedo utilizar el operador «O» para combinar criterios en CONTAR.SI?
    Sí, puedes utilizar el operador «O» (OR en inglés) para combinar criterios en la función CONTAR.SI utilizando la siguiente sintaxis:
    =CONTAR.SI(rango, criterio_1) + CONTAR.SI(rango, criterio_2)
    Esto te permitirá contar las celdas que cumplan el criterio_1 o el criterio_2.
  2. ¿Puedo utilizar el operador «Y» para combinar criterios en CONTAR.SI?
    No, la función CONTAR.SI no permite combinar criterios utilizando el operador «Y» (AND en inglés). Para combinar criterios, debes utilizar la función CONTAR.SI.CONJUNTO o fórmulas más complejas.
  3. ¿Puedo utilizar rangos no contiguos en CONTAR.SI?
    Sí, puedes utilizar rangos no contiguos en la función CONTAR.SI separando cada rango con una coma. Por ejemplo:
    =CONTAR.SI(rango_1, criterio) + CONTAR.SI(rango_2, criterio)
    Esto te permitirá contar las celdas que cumplan el criterio en ambos rangos no contiguos.

Ahora que conoces cómo utilizar la función CONTAR.SI en varias columnas, podrás hacer un seguimiento más eficiente de tus datos en Excel. Utiliza esta función para simplificar tus tareas de conteo y obtener información valiosa de manera rápida y sencilla.

Si deseas obtener más información sobre las funciones de Excel, puedes consultar la documentación oficial de Microsoft Excel en https://support.microsoft.com/es-ww/excel.

Deja un comentario