Cómo crear una curva de supervivencia en Excel

Seguramente has escuchado hablar de Excel, la herramienta de hojas de cálculo más popular del mundo. Es utilizada por millones de personas para realizar cálculos, organizar datos y analizar información. Sin embargo, ¿sabías que también puedes crear una curva de supervivencia en Excel? Esta poderosa función te permitirá visualizar y analizar datos de manera efectiva, especialmente en estudios de tiempo de vida y análisis de supervivencia. En este artículo, te guiaremos paso a paso para que aprendas cómo crear una curva de supervivencia en Excel. ¡Prepárate para descubrir una nueva forma de analizar tus datos y tomar decisiones informadas!


A curva de supervivencia Es un gráfico que muestra la proporción de una población que sigue viva después de una edad determinada, o en un momento determinado después de contraer algún tipo de enfermedad.

Este tutorial muestra cómo crear una curva de supervivencia en Excel.

Crear una curva de supervivencia en Excel

Supongamos que tenemos el siguiente conjunto de datos que muestra cuánto tiempo estuvo un paciente en un ensayo médico (columna A) y si el paciente todavía estaba vivo o no al final del ensayo (columna B).

Cómo crear una curva de supervivencia en Excel

Para crear una curva de supervivencia para estos datos, primero debemos obtener los datos en el formato correcto y luego usar los gráficos integrados de Excel para crear la curva.

Formatear los datos

Utilice los siguientes pasos para obtener los datos en el formato correcto.

Paso 1: Enumere todos los valores únicos de “Años en prueba” en la columna A de la columna D:

Nota: Incluya siempre “0” como primer valor.

Cómo crear una curva de supervivencia en Excel

Paso 2: Cree los valores en las columnas E a H usando las fórmulas que se muestran a continuación.

Nota: eliminamos el valor “18” en la columna D ya que no había valores de muerte asociados con ese momento.

Cómo crear una curva de supervivencia en Excel

Aquí están las fórmulas utilizadas en las siguientes celdas:

E3: =CONTAR.SI($A$2:$A$16,D3,$B$2:$B$16,1)
F2: =CONTAR.SI($A$2:$A$16, “>”&D2-1)
G3: =1-(E3/F3)
H2: =1
H3: =H2*G3

Para completar todos los demás valores en la columna E, simplemente resalte el rango E4:E13 y presione Ctrl-D. Complete todos los demás valores en las columnas F a H usando el mismo truco.

Ahora estamos listos para crear la curva de supervivencia.

Creando la curva de supervivencia

Utilice los siguientes pasos para crear la curva de supervivencia.

Paso 1: Copie los valores de las columnas D y H en las columnas J y K.

Cómo crear una curva de supervivencia en Excel

Paso 2: Copie los valores en el rango J3:J13 a J14:J24. Luego copie los valores en el rango K2:K12 a K14:K24.

Cómo crear una curva de supervivencia en Excel

Paso 3: cree una lista de valores en la columna L como se muestra a continuación, luego ordene de menor a mayor los valores en la columna L:

Cómo crear una curva de supervivencia en Excel
Crear lista de valores en la columna L
Cómo crear una curva de supervivencia en Excel
Ordene las columnas J a L de menor a mayor según la columna L

Paso 4: Resalte las celdas J2:K24, luego seleccione la opción “Insertar” > “Gráficos|Dispersión” > “Dispersión con líneas rectas y marcadores”.

No dude en modificar el título, los nombres de los ejes y los colores del gráfico. El gráfico resultante se verá así:

Cómo crear una curva de supervivencia en Excel
Error 403 The request cannot be completed because you have exceeded your quota. : quotaExceeded






Cómo crear una curva de supervivencia en Excel – Preguntas frecuentes

Preguntas frecuentes: Cómo crear una curva de supervivencia en Excel

1. ¿Qué es una curva de supervivencia en Excel?

Una curva de supervivencia es una representación gráfica que muestra la probabilidad de supervivencia de una población en función del tiempo. En Excel, puedes crear esta curva utilizando datos de una muestra o conjunto de datos.

2. ¿Cuáles son los pasos para crear una curva de supervivencia en Excel?

Los pasos para crear una curva de supervivencia en Excel son los siguientes:

  1. Prepara tus datos en columnas, donde la primera columna contenga el tiempo y la segunda columna contenga el porcentaje de supervivencia.
  2. Selecciona los datos y haz clic en la pestaña “Insertar” en la barra de menú.
  3. Haz clic en “Gráfico de dispersión” y selecciona la opción “Dispersión con líneas suavizadas”.
  4. Ahora tendrás tu curva de supervivencia en Excel.

3. ¿Cómo puedo obtener datos para crear una curva de supervivencia?

Puedes obtener datos para crear una curva de supervivencia a través de encuestas, estudios de investigación o registros médicos. Es importante contar con datos precisos y representativos de la población que deseas analizar.

4. ¿Existen otras herramientas o software para crear curvas de supervivencia?

Sí, además de Excel, existen otras herramientas y software especializados para crear curvas de supervivencia, como SPSS, R y SAS. Estos programas ofrecen funcionalidades más avanzadas y permiten un análisis más detallado de los datos.

5. ¿Hay recursos adicionales para aprender más sobre curvas de supervivencia en Excel?

Sí, aquí te dejamos algunos recursos adicionales para aprender más sobre cómo crear curvas de supervivencia en Excel:
Tutorial oficial de Microsoft sobre gráficos de supervivencia en Excel
Artículo en Excel Total sobre curvas de supervivencia en Excel
Material adicional de la Universidad RWTH Aachen (PDF)

¡Esperamos que encuentres útiles estos recursos adicionales para profundizar en el tema!


Deja un comentario